Rocksolid Light

groups  faq  privacy  How to post  login

Message-ID:  

Q: What do you have when you have a lawyer buried up to his neck in sand? A: Not enough sand.


rocksolid / de.comm.software.newsreader / Re: tin - Unterschied PCRE Versionen

SubjectAuthor
* tin - Unterschied PCRE VersionenClemens Schüller
`- Re: tin - Unterschied PCRE VersionenEnrik Berkhan

1
Subject: tin - Unterschied PCRE Versionen
From: Clemens Schüller
Newsgroups: de.comm.software.newsreader
Date: Fri, 5 Jan 2024 23:12 UTC
Path: i2pn2.org!i2pn.org!usenet.goja.nl.eu.org!3.eu.feeder.erje.net!feeder.erje.net!news-2.dfn.de!news.dfn.de!fu-berlin.de!uni-berlin.de!individual.net!not-for-mail
From: cs.use...@mailbox.org (Clemens Schüller)
Newsgroups: de.comm.software.newsreader
Subject: tin - Unterschied PCRE Versionen
Date: Sat, 06 Jan 2024 00:12:38 +0100
Lines: 75
Message-ID: <m2h6jr1ijd.fsf@cmschueller.my-fqdn.de>
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit
X-Trace: individual.net ac5eSTs9a47XwNl9aM6/XAEghnc3rZR6KG5zlkSUIluxK/9nQ+
Cancel-Lock: sha1:MyKoUIfRNvGzzDBsFT4BJmO0roY= sha1:MLm7reD7LGKJu7eAKgFVSYpg5Vg= sha256:O/Rq2Zbu9kZ+fplYCoAdqOjVxCahFF52lg2ewvCxYsQ=
User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/30.0.50 (darwin)
View all headers

Hallo zusammen!

Mir ist gerade aufgefallen, dass es bei tin unterschiedliche PCRE
Versionen gibt:

Installiert mit "brew install tin"

--8<---------------cut here---------------start------------->8---
Version: tin 2.6.3 Ausgabe 20231224 ("Banff") Dec 23 2023 23:39:16
Platform:
OS-Name = "darwin23.2.0"
Compiler:
CC = "clang"
CFLAGS = "-O2 -Qunused-arguments -Wno-error=implicit-function-declaration -I/opt/homebrew/Cellar/pcre2/10.42/include "
CPP = "clang -E"
CPPFLAGS = "-D_DARWIN_C_SOURCE"
Linker and Libraries:
LD = "clang"
LDFLAGS = ""
LIBS = " -lcurses -lz -L/opt/homebrew/Cellar/pcre2/10.42/lib -lpcre2-8 -liconv"
PCRE = "10.42 2022-12-11"
Characteristics:
-DEBUG +NNTP_ABLE -NNTPS_ABLE +USE_ZLIB -NO_POSTING -BROKEN_LISTGROUP +XHDR_XREF
-HAVE_FASCIST_NEWSADMIN +ENABLE_IPV6 -HAVE_COREFILE
-NO_SHELL_ESCAPE -DISABLE_PRINTING -DONT_HAVE_PIPING -NO_ETIQUETTE
+HAVE_LONG_FILE_NAMES +APPEND_PID -HAVE_MH_MAIL_HANDLING
-HAVE_ISPELL -HAVE_METAMAIL +HAVE_SUM
+HAVE_COLOR -HAVE_PGP -HAVE_PGPK -HAVE_GPG
+MIME_BREAK_LONG_LINES +MIME_STRICT_CHARSET +CHARSET_CONVERSION
+MULTIBYTE_ABLE -NO_LOCALE -USE_LONG_ARTICLE_NUMBERS
-USE_CANLOCK -EVIL_INSIDE -FORGERY -TINC_DNS -ENFORCE_RFC1034
-REQUIRE_BRACKETS_IN_DOMAIN_LITERAL -ALLOW_FWS_IN_NEWSGROUPLIST
--8<---------------cut here---------------end--------------->8---

Installiert aus den Sourcen von ftp.tin.org

--8<---------------cut here---------------start------------->8---
Version: tin 2.6.3 Ausgabe 20231224 ("Banff") Dec 24 2023 21:47:46
Platform:
OS-Name = "darwin23.2.0"
Compiler:
CC = "gcc"
CFLAGS = "-O2 -Qunused-arguments -Wno-error=implicit-function-declaration "
CPP = "gcc -E"
CPPFLAGS = "-D_DARWIN_C_SOURCE -I../intl"
Linker and Libraries:
LD = "gcc"
LDFLAGS = "-L /opt/homebrew/opt/openssl@3/lib"
LIBS = " -lcurses -lz -liconv"
PCRE = "7.0 18-Dec-2006"
Characteristics:
-DEBUG +NNTP_ABLE -NNTPS_ABLE +USE_ZLIB -NO_POSTING -BROKEN_LISTGROUP +XHDR_XREF
-HAVE_FASCIST_NEWSADMIN +ENABLE_IPV6 -HAVE_COREFILE
-NO_SHELL_ESCAPE -DISABLE_PRINTING -DONT_HAVE_PIPING -NO_ETIQUETTE
+HAVE_LONG_FILE_NAMES +APPEND_PID -HAVE_MH_MAIL_HANDLING
-HAVE_ISPELL -HAVE_METAMAIL +HAVE_SUM
+HAVE_COLOR -HAVE_PGP -HAVE_PGPK +HAVE_GPG
+MIME_BREAK_LONG_LINES +MIME_STRICT_CHARSET +CHARSET_CONVERSION
+MULTIBYTE_ABLE -NO_LOCALE -USE_LONG_ARTICLE_NUMBERS
-USE_CANLOCK -EVIL_INSIDE -FORGERY -TINC_DNS -ENFORCE_RFC1034
-REQUIRE_BRACKETS_IN_DOMAIN_LITERAL -ALLOW_FWS_IN_NEWSGROUPLIST
--8<---------------cut here---------------end--------------->8---

Gibt es einen bestimmten Grund, warum bei den Sourcen eine "uralte"
Version von PCRE verwendet wird? 🤷‍♂️

--
LieGrü aus Graz, Clemens

Subject: Re: tin - Unterschied PCRE Versionen
From: Enrik Berkhan
Newsgroups: de.comm.software.newsreader
Organization: void
Date: Sat, 6 Jan 2024 07:29 UTC
References: 1
Path: i2pn2.org!i2pn.org!weretis.net!feeder8.news.weretis.net!news.szaf.org!inka.de!chekov.starfleet.inka.de!starfleet.inka.de!.POSTED!not-for-mail
From: Enrik.Be...@inka.de (Enrik Berkhan)
Newsgroups: de.comm.software.newsreader
Subject: Re: tin - Unterschied PCRE Versionen
Date: Sat, 6 Jan 2024 07:29:29 -0000 (UTC)
Organization: void
Message-ID: <unavgp$4nh2$1@starfleet.inka.de>
References: <m2h6jr1ijd.fsf@cmschueller.my-fqdn.de>
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Injection-Info: starfleet.inka.de;
logging-data="155170"; mail-complaints-to="usenet@starfleet.inka.de"
User-Agent: tin/2.6.3-20230505 ("Pittyvaich") (Linux/6.1.0-17-amd64 (x86_64))
Cancel-Lock: sha256:mKlxjDqkVhrMVKULFN+/f4Z5F82IA+fX/ocCP/LlPXo=
View all headers

Clemens Schüller <cs.usenet@mailbox.org> wrote:
> Gibt es einen bestimmten Grund, warum bei den Sourcen eine "uralte"
> Version von PCRE verwendet wird? 🤷‍♂️

"Tradition". (tin bringt "schon immer" eine Kopie dieser Sourcen mit,
damit man ohne großen Zusatzaufwand auf Platformen bauen kann, die
pcre/pcre2 nicht von Haus aus haben.) Als ich die pcre2-Unterstützung
eingebaut habe, habe ich das nicht angefasst.

Wenn du pcre2 hast, kannst du beim `configure' z.B. auf das zugehörige
pcre2-config verweisen, dann sollte pcre2 verwendet werden:

.... --with-pcre2-config=/usr/bin/pcre2-config ...

(mit passendem pcre2-config Pfad natürlich).

Gruß,
Enrik


rocksolid / de.comm.software.newsreader / Re: tin - Unterschied PCRE Versionen

1
server_pubkey.txt

rocksolid light 0.9.12
clearnet tor